#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(:)[a-zA-Z]+"
Local $sString = "a:b" & @CRLF & _
"a.in:b" & @CRLF & _
"asds.sdsd:b" & @CRLF & _
"a:b___a.sds:bc___ab:bd"
Local $sSubst = "$1replaced"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)