package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(:)[a-zA-Z]+`)
var str = `a:b
a.in:b
asds.sdsd:b
a:b___a.sds:bc___ab:bd`
var substitution = "$1replaced"
fmt.Println(re.ReplaceAllString(str, substitution))
}