package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(<|>|!=|=)\d+([&|](<|>|!=|=)\d+)*`)
var str = `>50&<100
>30
<30
=10
!=10
>2|<5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}