$re = '/^(<|>|!=|=)\d+([&|](<|>|!=|=)\d+)*/m';
$str = '>50&<100
>30
<30
=10
!=10
>2|<5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);