re = /^(<|>|!=|=)\d+([&|](<|>|!=|=)\d+)*/m
str = '>50&<100
>30
<30
=10
!=10
>2|<5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end