package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^\s*"\s*|\s*"\s*$|\s*"?\s*,\s*"?\s*)`)
var str = `,Domestic Transactions,
Date ,Transaction Description ,Amount
,Rahul,
,,
12-01-2018,STIC TRAVELS PVT LTD DELHI ,32256 cr
13-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,211687
14-01-2018,FLEMINGO DUTY FREE Mumbai ,18796.99
14-01-2018,AIRTEL PAYMENT MUMBAI ,1297
14-01-2018,AIRTEL PAYMENT CHENNAI ,902 cr
22-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,5000
,,
,Ritu,
17-01-2018,PAYTM NOIDA ,165
17-01-2018,BIKANERVALA GURGAON ,325
19-01-2018,VFS GLOBAL SERVICES PVT MUMBAI ,1200
21-01-2018,Amazon Seller Services BANGALORE ,2155 cr
,,
,International Transactions,
Date ,Transaction Description ,Amount
,Rahul,
13-01-2018,SRILANKANUPGRADE KATUNAYAKE EUR,6
14-01-2018,HEALTHGUARD LIMITED KATUNAYAKE USD,5 cr
14-01-2018,FOOT RUB BERLIN EUR,20
20-01-2018,California Games CALIFORNIA USD,100
30-01-2018,NewYorkShop NEWYORK USD,200 cr
08-02-2018,EURO WINGS DUSSELDOR EUR,5
,,
,,
,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}