import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.* (REV|LIB) .*).*$";
final String string = "0,5 MG COM CT BL AL/AL X 30\n\n"
+ "0,4 MG COM REV CT BL AL AL X 90\n\n"
+ "0,7 MG COM LIB PROL CT BL AL AL X 30 \n\n"
+ "0,4 MG COM CT REV BL AL AL X 90";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}