const regex = /^(?!.* (REV|LIB) .*).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.* (REV|LIB) .*).*$', 'gm')
const str = `0,5 MG COM CT BL AL/AL X 30
0,4 MG COM REV CT BL AL AL X 90
0,7 MG COM LIB PROL CT BL AL AL X 30
0,4 MG COM CT REV BL AL AL X 90`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}