using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((http|https)\:\/\/|)([\w]+\.)+\w+($|[\w\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)";
string input = @"www.comohotels.com/metropolitanlondon
www.comohotels.com
www.comohotels.com/metropolitanlondon/dawdwad/fsef/rdgdr_szg/gsedg?btfbftb=fgersg&gdsrzgrg=rsths.sfra
xrftjcomjfcgyvhj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}