re = /^((http|https)\:\/\/|)([\w]+\.)+\w+($|[\w\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)/m
str = 'www.comohotels.com/metropolitanlondon
www.comohotels.com
www.comohotels.com/metropolitanlondon/dawdwad/fsef/rdgdr_szg/gsedg?btfbftb=fgersg&gdsrzgrg=rsths.sfra
xrftjcomjfcgyvhj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end