$re = '/^((http|https)\:\/\/|)([\w]+\.)+\w+($|[\w\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)/m';
$str = 'www.comohotels.com/metropolitanlondon
www.comohotels.com
www.comohotels.com/metropolitanlondon/dawdwad/fsef/rdgdr_szg/gsedg?btfbftb=fgersg&gdsrzgrg=rsths.sfra
xrftjcomjfcgyvhj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);