using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{% codepen '(.+?)',\s*'(.+?)',\s*'(.+?)' %}";
string input = @"{% codepen 'String1', 'String2', 'String3' %}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}