$re = '/{% codepen \'(.+?)\',\s*\'(.+?)\',\s*\'(.+?)\' %}/mU';
$str = '{% codepen \'String1\', \'String2\', \'String3\' %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);