re = /{% codepen '(.+?)',\s*'(.+?)',\s*'(.+?)' %}/m
str = '{% codepen \'String1\', \'String2\', \'String3\' %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end