using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+ \d+\/\d+\/\d+ (\d+[\.\d]*)";
string input = @"SOMEDATA .test 01/45/12 2.50 THIS IS DATA
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}