re = /.+ \d+\/\d+\/\d+ (\d+[\.\d]*)/
str = 'SOMEDATA .test 01/45/12 2.50 THIS IS DATA
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end