$re = '/.+ \d+\/\d+\/\d+ (\d+[\.\d]*)/';
$str = 'SOMEDATA .test 01/45/12 2.50 THIS IS DATA
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);