# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[font=([a-zA-Z]+)\](.*?)\[\\/font\]/<span style="font-family:$1">$2<\/span>/;t' <<< "[font=Arial\" style=\"top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[font=Arial]We are safe, phew![/font]"