// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[font=([a-zA-Z]+)\](.*?)\[\/font\]").unwrap();
let string = "[font=Arial\" style=\"top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[font=Arial]We are safe, phew![/font]";
let substitution = "<span style=\"font-family:$1\">$2</span>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}