use strict;
my $str = '[font=Arial" style="top:0;position:absolute;z-index:999;background:yellow;color:red;font-size:120pt;min-height:100%;]DEFACED[/font]
[font=Arial]We are safe, phew![/font]';
my $regex = qr/\[font=([a-zA-Z]+)\](.*?)\[\/font\]/p;
my $subst = '<span style="font-family:$1">$2</span>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";