#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{9}"
Local $sString = "blabla n123456789 bla bla 78 texto..." & @CRLF & _
" 987654321! texto qualquer 12 blaa" & @CRLF & _
" 123 bla blum 123741852 bobobl" & @CRLF & _
" blablum 12345678901 papumpa..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")