re = /\d{9}/
str = 'blabla n123456789 bla bla 78 texto...
987654321! texto qualquer 12 blaa
123 bla blum 123741852 bobobl
blablum 12345678901 papumpa...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end