package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{9}`)
var str = `blabla n123456789 bla bla 78 texto...
987654321! texto qualquer 12 blaa
123 bla blum 123741852 bobobl
blablum 12345678901 papumpa...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}