const regex = /^(?i)[T]20\d{6}.\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)[T]20\\d{6}.\\d{4}$', 'gm')
const str = `t20160307.0001
T20160201.0003
y20160202.0001
T20163022.11157
t2016o302.0001
T21160302.0001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}