re = /^(?i)[T]20\d{6}.\d{4}$/m
str = 't20160307.0001
T20160201.0003
y20160202.0001
T20163022.11157
t2016o302.0001
T21160302.0001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end