// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?i)[T]20\d{6}.\d{4}$").unwrap();
let string = "t20160307.0001
T20160201.0003
y20160202.0001
T20163022.11157
t2016o302.0001
T21160302.0001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}