#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?i)[T]20[0-9]{2}[0-1][0-9][0-3][0-9].\d{4}$"
Local $sString = "t20160307.0001" & @CRLF & _
"T20160201.0003" & @CRLF & _
"y20160202.0001" & @CRLF & _
"T20163022.11157" & @CRLF & _
"t2016o302.0001" & @CRLF & _
"T21160302.0001"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")