package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)[T]20[0-9]{2}[0-1][0-9][0-3][0-9].\d{4}$`)
var str = `t20160307.0001
T20160201.0003
y20160202.0001
T20163022.11157
t2016o302.0001
T21160302.0001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}