import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)[T]20[0-9]{2}[0-1][0-9][0-3][0-9].\\d{4}$";
final String string = "t20160307.0001\n"
+ "T20160201.0003\n"
+ "y20160202.0001\n"
+ "T20163022.11157\n"
+ "t2016o302.0001\n"
+ "T21160302.0001";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}