#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((https?:\/\/|(ftp:\/\/)).*|(.*\.[^\.]{2,6})(\/.*)?)(\:.*)?$"
Local $sString = "Regex for http/https/ftp or only domain url" & @CRLF & _
"" & @CRLF & _
"Examples:" & @CRLF & _
"https://example.domain/page?=78" & @CRLF & _
"http://example.domain/page?=78" & @CRLF & _
"ftp://192.168.0.1:80" & @CRLF & _
"example.domain" & @CRLF & _
"example.domain:80/test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")