using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((https?:\/\/|(ftp:\/\/)).*|(.*\.[^\.]{2,6})(\/.*)?)(\:.*)?$";
string input = @"Regex for http/https/ftp or only domain url
Examples:
https://example.domain/page?=78
http://example.domain/page?=78
ftp://192.168.0.1:80
example.domain
example.domain:80/test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}