$re = '/((https?:\/\/|(ftp:\/\/)).*|(.*\.[^\.]{2,6})(\/.*)?)(\:.*)?$/m';
$str = 'Regex for http/https/ftp or only domain url
Examples:
https://example.domain/page?=78
http://example.domain/page?=78
ftp://192.168.0.1:80
example.domain
example.domain:80/test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);