use strict;
my $str = '[{"status":"success"}
{"values":{"cpu":26.5152886753948387,"ram":0.8452846061135513},"origin":"core","type":-1,"uuid":"0000-e8-de-27-176d10"}
{"values":{"cpu":25.5839236550189568,"ram":0.8452846061135513},"origin":"core","type":-1,"uuid":"0000-e8-de-27-176d10"}
]';
my $regex = qr/}(?!\s*[,\]])/mp;
my $subst = '},';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";