const regex = /(?<!set)\s\d{2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!set)\\s\\d{2,}', 'g')
const str = `Kabouter plop voetbal set 12345 en 12345 van het balkon vierkant 12345 12345 ijsbeer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}