re = /(?<!set)\s\d{2,}/
str = 'Kabouter plop voetbal set 12345 en 12345 van het balkon vierkant 12345 12345 ijsbeer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end