$re = '/(?<!set)\s\d{2,}/';
$str = 'Kabouter plop voetbal set 12345 en 12345 van het balkon vierkant 12345 12345 ijsbeer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);