package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*Wheels[^\d]*(\d*)x`)
var str = `Wheels – F/R_ Schwalbe TABLE TOP/Schwalbe Black Jack 26x2.2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}