import Foundation
let pattern = #".*Wheels[^\d]*(\d*)x"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Wheels – F/R_ Schwalbe TABLE TOP/Schwalbe Black Jack 26x2.2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}