package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PT((?<hours>.*)H)?((?<minutes>.*)M)?((?<seconds>.*)S)?`)
var str = `PT1H2M3S
PT3S
PT2M3S
PT1H
PT1H2M
PT1H3S`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}