const regex = /PT((?<hours>.*)H)?((?<minutes>.*)M)?((?<seconds>.*)S)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PT((?<hours>.*)H)?((?<minutes>.*)M)?((?<seconds>.*)S)?', 'gm')
const str = `PT1H2M3S
PT3S
PT2M3S
PT1H
PT1H2M
PT1H3S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}