use strict;
my $str = 'PT1H2M3S
PT3S
PT2M3S
PT1H
PT1H2M
PT1H3S';
my $regex = qr/PT((?<hours>.*)H)?((?<minutes>.*)M)?((?<seconds>.*)S)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}