package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<skip>\[(?:[^][]++|(?&skip))*])(*SKIP)(*FAIL)|\w+`)
var str = `[some [[text] here] and [[t]h[e][r[e]]]] and some text here [some [[text] here] and [[t]h[e][r[e]]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}