$re = '/(?<skip>\[(?:[^][]++|(?&skip))*])(*SKIP)(*FAIL)|\w+/m';
$str = '[some [[text] here] and [[t]h[e][r[e]]]] and some text here [some [[text] here] and [[t]h[e][r[e]]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);