re = /(?<skip>\[(?:[^][]++|(?&skip))*])(*SKIP)(*FAIL)|\w+/m
str = '[some [[text] here] and [[t]h[e][r[e]]]] and some text here [some [[text] here] and [[t]h[e][r[e]]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end