package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*](*SKIP)(*FAIL)|\w+`)
var str = `[some text here] and some text here [some text here]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}