$re = '/\[[^][]*](*SKIP)(*FAIL)|\w+/m';
$str = '[some text here] and some text here [some text here]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);