re = /\[[^][]*](*SKIP)(*FAIL)|\w+/m
str = '[some text here] and some text here [some text here]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end