const regex = new RegExp('[?&]sort_by=[^&]*$|(?<=[?&])sort_by=[^&]*&', 'gm')
const str = `?sort_by=name&role=user
?gender=male&sort_by=name_desc&role=user
?sort_by=name
?age=24&sort_by=fullname&gender=male
?age=24&sort_by=fullname`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);