# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[?&]sort_by=[^&]*$|(?<=[?&])sort_by=[^&]*&"
test_str = ("?sort_by=name&role=user\n"
"?gender=male&sort_by=name_desc&role=user\n"
"?sort_by=name\n"
"?age=24&sort_by=fullname&gender=male\n"
"?age=24&sort_by=fullname")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.