re = /[?&]sort_by=[^&]*$|(?<=[?&])sort_by=[^&]*&/m
str = '?sort_by=name&role=user
?gender=male&sort_by=name_desc&role=user
?sort_by=name
?age=24&sort_by=fullname&gender=male
?age=24&sort_by=fullname'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result